Installation instructions

To install developing version of Aptitude with Qt frontend, you need to download a current snapshot of the code. Snapshots are available at link:


Next step is installing are required dependencies:

aptitude install \
libapt-pkg-dev libsigc++-2.0-dev libcppunit-dev libcwidget-dev gettext g++ make
docbook-xsl docbook-xml xsltproc html2text po4a # documentation libqt4-dev

To compile

./configure --enable-qt
make -j
sudo make install

To run:
sudo aptitude --qt